CVE-2019-7329

Name
CVE-2019-7329
Description
Reflected Cross Site Scripting (XSS) exists in ZoneMinder through 1.32.3, as the form action on multiple views utilizes $_SERVER['PHP_SELF'] insecurely, mishandling any arbitrary input appended to the webroot URL, without any proper filtration, leading to XSS.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Exploit https://github.com/ZoneMinder/zoneminder/issues/2446

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:zoneminder:zoneminder:*:*:*:*:*:*:*:* zoneminder >= None <= 1.32.3

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
zoneminder 3.14-community 1.32.3-r4 Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi> possibly vulnerable
zoneminder edge-community 1.32.3-r5 Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi> possibly vulnerable