CVE-2019-5737

Name
CVE-2019-5737
Description
In Node.js including 6.x before 6.17.0, 8.x before 8.15.1, 10.x before 10.15.2, and 11.x before 11.10.1, an attacker can cause a Denial of Service (DoS) by establishing an HTTP or HTTPS connection in keep-alive mode and by sending headers very slowly. This keeps the connection and associated resources alive for a long period of time. Potential attacks are mitigated by the use of a load balancer or other proxy layer. This vulnerability is an extension of CVE-2018-12121, addressed in November and impacts all active Node.js release lines including 6.x before 6.17.0, 8.x before 8.15.1, 10.x before 10.15.2, and 11.x before 11.10.1.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Third Party Advisory https://nodejs.org/en/blog/vulnerability/february-2019-security-releases/
Mailing List http://lists.opensuse.org/opensuse-security-announce/2019-03/msg00041.html
Mailing List http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00046.html
Mailing List http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00059.html
Third Party Advisory https://security.netapp.com/advisory/ntap-20190502-0008/
Third Party Advisory https://access.redhat.com/errata/RHSA-2019:1821
Third Party Advisory https://security.gentoo.org/glsa/202003-48

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:* nodejs >= 6.0.0 < 6.17.0
cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:* nodejs >= 11.0.0 < 11.10.1
cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:* nodejs >= 10.0.0 < 10.15.2
cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:* nodejs >= 8.0.0 < 8.15.1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status