CVE-2019-3466

Name
CVE-2019-3466
Description
The pg_ctlcluster script in postgresql-common in versions prior to 210 didn't drop privileges when creating socket/statistics temporary directories, which could result in local privilege escalation.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Exploit https://blog.mirch.io/2019/11/15/cve-2019-3466-debian-ubuntu-pg_ctlcluster-privilege-escalation/
UBUNTU https://usn.ubuntu.com/4194-2/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:postgresql:postgresql-common:*:*:*:*:*:*:*:* postgresql-common >= None < 210

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
postgresql-common edge-main 1.0-r0 Jakub Jirutka <jakub@jirutka.cz> possibly vulnerable