CVE-2019-20840

Name
CVE-2019-20840
Description
An issue was discovered in LibVNCServer before 0.9.13. libvncserver/ws_decode.c can lead to a crash because of unaligned accesses in hybiReadAndDecode.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Release Notes https://github.com/LibVNC/libvncserver/compare/LibVNCServer-0.9.12...LibVNCServer-0.9.13
Patch https://github.com/LibVNC/libvncserver/commit/0cf1400c61850065de590d403f6d49e32882fd76
Mailing List https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/4F6FUH4EFK4NAP6GT4TQRTBKWIRCZLIY/
Mailing List http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00033.html
Mailing List http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00055.html
SUSE http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00066.html
UBUNTU https://usn.ubuntu.com/4434-1/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:libvncserver_project:libvncserver:*:*:*:*:*:*:*:* libvncserver >= None < 0.9.13

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
libvncserver 3.11-main 0.9.12-r1 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable