CVE-2019-20218

Name
CVE-2019-20218
Description
selectExpander in select.c in SQLite 3.30.1 proceeds with WITH stack unwinding even after a parsing error.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Patch https://github.com/sqlite/sqlite/commit/a6c1a71cde082e09750465d5675699062922e387
UBUNTU https://usn.ubuntu.com/4298-1/
N/A https://www.oracle.com/security-alerts/cpuapr2020.html
GENTOO https://security.gentoo.org/glsa/202007-26
MLIST https://lists.debian.org/debian-lts-announce/2020/08/msg00037.html
MLIST https://lists.debian.org/debian-lts-announce/2020/12/msg00016.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:sqlite:sqlite:3.30.1:*:*:*:*:*:*:* sqlite == None == 3.30.1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
sqlite 3.11-main 3.30.1-r2 Carlo Landmeter <clandmeter@gmail.com> possibly vulnerable