CVE-2019-19204

Name
CVE-2019-19204
Description
An issue was discovered in Oniguruma 6.x before 6.9.4_rc2. In the function fetch_interval_quantifier (formerly known as fetch_range_quantifier) in regparse.c, PFETCH is called without checking PEND. This leads to a heap-based buffer over-read.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Exploit https://github.com/kkos/oniguruma/issues/162
Release Notes https://github.com/kkos/oniguruma/releases/tag/v6.9.4_rc2
Exploit https://github.com/ManhNDd/CVE-2019-19204
Third Party Advisory https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/NO267PLHGYZSWX3XTRPKYBKD4J3YOU5V/
Third Party Advisory https://lists.debian.org/debian-lts-announce/2019/12/msg00002.html
Third Party Advisory https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/V3MBNW6Z4DOXSCNWGBLQ7OA3OGUJ44WL/
Third Party Advisory https://github.com/tarantula-team/CVE-2019-19204
UBUNTU https://usn.ubuntu.com/4460-1/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:oniguruma_project:oniguruma:*:*:*:*:*:*:*:* oniguruma >= 6.0.0 < 6.9.4
cpe:2.3:a:oniguruma_project:oniguruma:6.9.4:rc1:*:*:*:*:*:* oniguruma == None == 6.9.4

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
oniguruma 3.11-main 6.9.4-r1 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable