CVE-2019-17542

Name
CVE-2019-17542
Description
FFmpeg before 4.2 has a heap-based buffer overflow in vqa_decode_chunk because of an out-of-array access in vqa_decode_init in libavcodec/vqavideo.c.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Patch https://github.com/FFmpeg/FFmpeg/commit/02f909dc24b1f05cfbba75077c7707b905e63cd2
Issue Tracking https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=15919
Mailing List https://lists.debian.org/debian-lts-announce/2019/12/msg00003.html
Third Party Advisory https://security.gentoo.org/glsa/202003-65
Third Party Advisory https://www.debian.org/security/2020/dsa-4722
Mailing List https://lists.debian.org/debian-lts-announce/2020/07/msg00022.html
Third Party Advisory https://usn.ubuntu.com/4431-1/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:ffmpeg:ffmpeg:*:*:*:*:*:*:*:* ffmpeg >= None < 2.8.16
cpe:2.3:a:ffmpeg:ffmpeg:*:*:*:*:*:*:*:* ffmpeg >= 3.2 < 3.2.15
cpe:2.3:a:ffmpeg:ffmpeg:*:*:*:*:*:*:*:* ffmpeg >= 3.4 < 3.4.7
cpe:2.3:a:ffmpeg:ffmpeg:*:*:*:*:*:*:*:* ffmpeg >= 4.0 < 4.0.5
cpe:2.3:a:ffmpeg:ffmpeg:*:*:*:*:*:*:*:* ffmpeg >= 4.1 < 4.1.5

Vulnerable and fixed packages

Source package Branch Version Maintainer Status