CVE-2019-17017

Name
CVE-2019-17017
Description
Due to a missing case handling object types, a type confusion vulnerability could occur, resulting in a crash. We presume that with enough effort that it could be exploited to run arbitrary code. This vulnerability affects Firefox ESR < 68.4 and Firefox < 72.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Permissions Required https://bugzilla.mozilla.org/show_bug.cgi?id=1603055
Vendor Advisory https://www.mozilla.org/security/advisories/mfsa2020-01/
Vendor Advisory https://www.mozilla.org/security/advisories/mfsa2020-02/
Mailing List https://seclists.org/bugtraq/2020/Jan/12
Mailing List https://lists.debian.org/debian-lts-announce/2020/01/msg00005.html
Third Party Advisory https://www.debian.org/security/2020/dsa-4600
Third Party Advisory https://usn.ubuntu.com/4234-1/
Third Party Advisory https://seclists.org/bugtraq/2020/Jan/18
Third Party Advisory https://access.redhat.com/errata/RHSA-2020:0086
Third Party Advisory https://access.redhat.com/errata/RHSA-2020:0085
MISC http://packetstormsecurity.com/files/155912/Slackware-Security-Advisory-mozilla-thunderbird-Updates.html
REDHAT https://access.redhat.com/errata/RHSA-2020:0111
SUSE http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00029.html
REDHAT https://access.redhat.com/errata/RHSA-2020:0123
REDHAT https://access.redhat.com/errata/RHSA-2020:0120
REDHAT https://access.redhat.com/errata/RHSA-2020:0127
UBUNTU https://usn.ubuntu.com/4241-1/
DEBIAN https://www.debian.org/security/2020/dsa-4603
BUGTRAQ https://seclists.org/bugtraq/2020/Jan/26
MLIST https://lists.debian.org/debian-lts-announce/2020/01/msg00016.html
SUSE http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00043.html
REDHAT https://access.redhat.com/errata/RHSA-2020:0295
REDHAT https://access.redhat.com/errata/RHSA-2020:0292
GENTOO https://security.gentoo.org/glsa/202003-02
UBUNTU https://usn.ubuntu.com/4335-1/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:mozilla:firefox:*:*:*:*:*:*:*:* firefox >= None < 72.0
cpe:2.3:a:mozilla:firefox_esr:*:*:*:*:*:*:*:* firefox_esr >= None < 68.4

Vulnerable and fixed packages

Source package Branch Version Maintainer Status