CVE-2019-16547

Name
CVE-2019-16547
Description
Missing permission checks in various API endpoints in Jenkins Google Compute Engine Plugin 4.1.1 and earlier allow attackers with Overall/Read permission to obtain limited information about the plugin configuration and environment.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Vendor Advisory https://jenkins.io/security/advisory/2019-11-21/#SECURITY-1585
Mailing List http://www.openwall.com/lists/oss-security/2019/11/21/1

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:google_compute_engine:*:*:*:*:*:jenkins:*:* jenkins >= None < 4.2.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.14-community 2.297-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.307-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable