CVE-2019-16201

Name
CVE-2019-16201
Description
WEBrick::HTTPAuth::DigestAuth in Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 has a regular expression Denial of Service cause by looping/backtracking. A victim must expose a WEBrick server that uses DigestAuth to the Internet or a untrusted network.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Third Party Advisory https://hackerone.com/reports/661722
Mailing List https://lists.debian.org/debian-lts-announce/2019/11/msg00025.html
MLIST https://lists.debian.org/debian-lts-announce/2019/12/msg00009.html
BUGTRAQ https://seclists.org/bugtraq/2019/Dec/32
BUGTRAQ https://seclists.org/bugtraq/2019/Dec/31
DEBIAN https://www.debian.org/security/2019/dsa-4587
MISC https://www.oracle.com/security-alerts/cpujan2020.html
GENTOO https://security.gentoo.org/glsa/202003-06
SUSE http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00041.html
MLIST https://lists.debian.org/debian-lts-announce/2020/08/msg00027.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:ruby-lang:ruby:*:*:*:*:*:*:*:* ruby >= 2.4.0 <= 2.4.7
cpe:2.3:a:ruby-lang:ruby:*:*:*:*:*:*:*:* ruby >= 2.5.0 <= 2.5.6
cpe:2.3:a:ruby-lang:ruby:*:*:*:*:*:*:*:* ruby >= 2.6.0 <= 2.6.4

Vulnerable and fixed packages

Source package Branch Version Maintainer Status