CVE-2019-15681

Name
CVE-2019-15681
Description
LibVNC commit before d01e1bb4246323ba6fcee3b82ef1faa9b1dac82a contains a memory leak (CWE-655) in VNC server code, which allow an attacker to read stack memory and can be abused for information disclosure. Combined with another vulnerability, it can be used to leak stack memory and bypass ASLR. This attack appear to be exploitable via network connectivity. These vulnerabilities have been fixed in commit d01e1bb4246323ba6fcee3b82ef1faa9b1dac82a.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Patch https://github.com/LibVNC/libvncserver/commit/d01e1bb4246323ba6fcee3b82ef1faa9b1dac82a
Mailing List https://lists.debian.org/debian-lts-announce/2019/10/msg00039.html
Mailing List https://lists.debian.org/debian-lts-announce/2019/10/msg00042.html
Mailing List https://lists.debian.org/debian-lts-announce/2019/11/msg00032.html
Mailing List https://lists.debian.org/debian-lts-announce/2019/12/msg00028.html
Mailing List http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00027.html
Third Party Advisory https://usn.ubuntu.com/4407-1/
Mailing List http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00073.html
Third Party Advisory https://usn.ubuntu.com/4547-1/
Third Party Advisory https://usn.ubuntu.com/4573-1/
UBUNTU https://usn.ubuntu.com/4587-1/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:libvnc_project:libvncserver:0.9.12:-:*:*:*:*:*:* libvncserver == None == 0.9.12

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
libvncserver 3.11-main 0.9.12-r1 Natanael Copa <ncopa@alpinelinux.org> fixed
libvncserver 3.10-main 0.9.11-r3 None fixed