CVE-2019-13307

Name
CVE-2019-13307
Description
ImageMagick 7.0.8-50 Q16 has a heap-based buffer overflow at MagickCore/statistic.c in EvaluateImages because of mishandling rows.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Patch https://github.com/ImageMagick/ImageMagick/commit/025e77fcb2f45b21689931ba3bf74eac153afa48
Exploit https://github.com/ImageMagick/ImageMagick/issues/1615
Patch https://github.com/ImageMagick/ImageMagick6/commit/91e58d967a92250439ede038ccfb0913a81e59fe
SUSE http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00069.html
UBUNTU https://usn.ubuntu.com/4192-1/
DEBIAN https://www.debian.org/security/2020/dsa-4712
DEBIAN https://www.debian.org/security/2020/dsa-4715

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:imagemagick:imagemagick:7.0.8-50:q16:*:*:*:*:*:* imagemagick == None == 7.0.8-50

Vulnerable and fixed packages

Source package Branch Version Maintainer Status