CVE-2019-13057

Name
CVE-2019-13057
Description
An issue was discovered in the server in OpenLDAP before 2.4.48. When the server administrator delegates rootDN (database admin) privileges for certain databases but wants to maintain isolation (e.g., for multi-tenant deployments), slapd does not properly stop a rootDN from requesting authorization as an identity from another database during a SASL bind or with a proxyAuthz (RFC 4370) control. (It is not a common configuration to deploy a system where the server administrator and a DB administrator enjoy different levels of trust.)
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Mailing List https://www.openldap.org/lists/openldap-announce/201907/msg00001.html
Mailing List https://www.openldap.org/its/?findid=9038
Third Party Advisory https://usn.ubuntu.com/4078-1/
MLIST https://lists.debian.org/debian-lts-announce/2019/08/msg00024.html
UBUNTU https://usn.ubuntu.com/4078-2/
CONFIRM https://security.netapp.com/advisory/ntap-20190822-0004/
SUSE http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00053.html
SUSE http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00058.html
CONFIRM https://support.apple.com/kb/HT210788
BUGTRAQ https://seclists.org/bugtraq/2019/Dec/23
FULLDISC http://seclists.org/fulldisclosure/2019/Dec/26
N/A https://www.oracle.com/security-alerts/cpuapr2020.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:openldap:openldap:*:*:*:*:*:*:*:* openldap >= None < 2.4.48

Vulnerable and fixed packages

Source package Branch Version Maintainer Status