CVE-2019-10218

Name
CVE-2019-10218
Description
A flaw was found in the samba client, all samba versions before samba 4.11.2, 4.10.10 and 4.9.15, where a malicious server can supply a pathname to the client with separators. This could allow the client to access files and folders outside of the SMB network pathnames. An attacker could use this vulnerability to create files outside of the current working directory using the privileges of the client user.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Vendor Advisory https://www.samba.org/samba/security/CVE-2019-10218.html
Issue Tracking https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10218
Third Party Advisory http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00015.html
Third Party Advisory https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/UMIYCYXCPRTVCVZ3TP6ZGPJ6RZS3IX4G/
Third Party Advisory https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/OKPYHDFI7HRELVXBE5J4MTGSI35AKFBI/
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/XQ3IUACPZJXSC4OM6P2V4IC4QMZQZWPD/
CONFIRM https://www.synology.com/security/advisory/Synology_SA_19_35
MLIST https://lists.debian.org/debian-lts-announce/2021/05/msg00023.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:* samba >= 4.11.0 < 4.11.2
cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:* samba >= 4.10.0 < 4.10.10
cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:* samba >= None < 4.9.15

Vulnerable and fixed packages

Source package Branch Version Maintainer Status