CVE-2019-10063

Name
CVE-2019-10063
Description
Flatpak before 1.0.8, 1.1.x and 1.2.x before 1.2.4, and 1.3.x before 1.3.1 allows a sandbox bypass. Flatpak versions since 0.8.1 address CVE-2017-5226 by using a seccomp filter to prevent sandboxed apps from using the TIOCSTI ioctl, which could otherwise be used to inject commands into the controlling terminal so that they would be executed outside the sandbox after the sandboxed app exits. This fix was incomplete: on 64-bit platforms, the seccomp filter could be bypassed by an ioctl request number that has TIOCSTI in its 32 least significant bits and an arbitrary nonzero value in its 32 most significant bits, which the Linux kernel would treat as equivalent to TIOCSTI.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Issue Tracking https://github.com/flatpak/flatpak/issues/2782
REDHAT https://access.redhat.com/errata/RHSA-2019:1024
REDHAT https://access.redhat.com/errata/RHSA-2019:1143

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:flatpak:flatpak:1.3.0:*:*:*:*:*:*:* flatpak == None == 1.3.0
cpe:2.3:a:flatpak:flatpak:*:*:*:*:*:*:*:* flatpak >= 1.2.0 < 1.2.4
cpe:2.3:a:flatpak:flatpak:*:*:*:*:*:*:*:* flatpak >= None < 1.0.8
cpe:2.3:a:flatpak:flatpak:*:*:*:*:*:*:*:* flatpak >= 1.1.0 <= 1.1.3

Vulnerable and fixed packages

Source package Branch Version Maintainer Status