CVE-2019-0211

Name
CVE-2019-0211
Description
In Apache HTTP Server 2.4 releases 2.4.17 to 2.4.38, with MPM event, worker or prefork, code executing in less-privileged child processes or threads (including scripts executed by an in-process scripting interpreter) could execute arbitrary code with the privileges of the parent process (usually root) by manipulating the scoreboard. Non-Unix systems are not affected.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Exploit https://www.exploit-db.com/exploits/46676/
Third Party Advisory https://www.debian.org/security/2019/dsa-4422
Third Party Advisory https://usn.ubuntu.com/3937-1/
Mailing List https://seclists.org/bugtraq/2019/Apr/5
Mailing List https://seclists.org/bugtraq/2019/Apr/16
Third Party Advisory https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WETXNQWNQLWHV6XNW6YTO5UGDTIWAQGT/
Third Party Advisory https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/EZRMTEIGZKYFNGIDOTXN3GNEJTLVCYU7/
Mailing List https://lists.apache.org/thread.html/b1613d44ec364c87bb7ee8c5939949f9b061c05c06e0e90098ebf7aa@%3Cusers.httpd.apache.org%3E
Vendor Advisory https://httpd.apache.org/security/vulnerabilities_24.html
Third Party Advisory http://www.securityfocus.com/bid/107666
Mailing List http://www.openwall.com/lists/oss-security/2019/04/02/3
Vendor Advisory http://www.apache.org/dist/httpd/CHANGES_2.4.39
Exploit http://packetstormsecurity.com/files/152441/CARPE-DIEM-Apache-2.4.x-Local-Privilege-Escalation.html
Third Party Advisory http://packetstormsecurity.com/files/152415/Slackware-Security-Advisory-httpd-Updates.html
Third Party Advisory http://packetstormsecurity.com/files/152386/Apache-2.4.38-Root-Privilege-Escalation.html
Mailing List https://lists.apache.org/thread.html/890507b85c30adf133216b299cc35cd8cd0346a885acfc671c04694e@%3Cdev.community.apache.org%3E
Mailing List https://lists.apache.org/thread.html/b2bdb308dc015e771ba79c0586b2de6fb50caa98b109833f5d4daf28@%3Cdev.community.apache.org%3E
Third Party Advisory https://access.redhat.com/errata/RHSA-2019:0746
Mailing List http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00051.html
Mailing List https://lists.apache.org/thread.html/de881a130bc9cb2f3a9ff220784520556884fb8ea80e69400a45509e@%3Cdev.community.apache.org%3E
Third Party Advisory https://support.f5.com/csp/article/K32957101
Mailing List http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00061.html
Third Party Advisory https://security.gentoo.org/glsa/201904-20
Third Party Advisory https://security.netapp.com/advisory/ntap-20190423-0001/
Third Party Advisory http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00084.html
REDHAT https://access.redhat.com/errata/RHSA-2019:0980
REDHAT https://access.redhat.com/errata/RHBA-2019:0959
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/ALIR5S3O7NRHEGFMIDMUSYQIZOE4TJJN/
CONFIRM https://www.synology.com/security/advisory/Synology_SA_19_14
REDHAT https://access.redhat.com/errata/RHSA-2019:1297
REDHAT https://access.redhat.com/errata/RHSA-2019:1296
MLIST https://lists.apache.org/thread.html/fd110f4ace2d8364c7d9190e1993cde92f79e4eb85576ed9285686ac@%3Ccvs.httpd.apache.org%3E
REDHAT https://access.redhat.com/errata/RHSA-2019:1543
MISC https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html
MLIST http://www.openwall.com/lists/oss-security/2019/07/26/7
MLIST https://lists.apache.org/thread.html/84a3714f0878781f6ed84473d1a503d2cc382277e100450209231830@%3Ccvs.httpd.apache.org%3E
MLIST https://lists.apache.org/thread.html/56c2e7cc9deb1c12a843d0dc251ea7fd3e7e80293cde02fcd65286ba@%3Ccvs.httpd.apache.org%3E
CONFIRM https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbux03950en_us
MISC https://www.oracle.com/technetwork/security-advisory/cpuoct2019-5072832.html
MLIST https://lists.apache.org/thread.html/r6d03e45b81eab03580cf7f8bb51cb3e9a1b10a2cc0c6a2d3cc92ed0c@%3Cannounce.apache.org%3E
MLIST https://lists.apache.org/thread.html/rd18c3c43602e66f9cdcf09f1de233804975b9572b0456cc582390b6f@%3Ccvs.httpd.apache.org%3E
MLIST https://lists.apache.org/thread.html/re3d27b6250aa8548b8845d314bb8a350b3df326cacbbfdfe4d455234@%3Ccvs.httpd.apache.org%3E
N/A https://www.oracle.com/security-alerts/cpuapr2020.html
MLIST https://lists.apache.org/thread.html/rf6449464fd8b7437704c55f88361b66f12d5b5f90bcce66af4be4ba9@%3Ccvs.httpd.apache.org%3E
MLIST https://lists.apache.org/thread.html/r9f93cf6dde308d42a9c807784e8102600d0397f5f834890708bf6920@%3Ccvs.httpd.apache.org%3E
MLIST https://lists.apache.org/thread.html/rd2fb621142e7fa187cfe12d7137bf66e7234abcbbcd800074c84a538@%3Ccvs.httpd.apache.org%3E
MLIST https://lists.apache.org/thread.html/r06f0d87ebb6d59ed8379633f36f72f5b1f79cadfda72ede0830b42cf@%3Ccvs.httpd.apache.org%3E
MLIST https://lists.apache.org/thread.html/rc998b18880df98bafaade071346690c2bc1444adaa1a1ea464b93f0a@%3Ccvs.httpd.apache.org%3E
MLIST https://lists.apache.org/thread.html/r03ee478b3dda3e381fd6189366fa7af97c980d2f602846eef935277d@%3Ccvs.httpd.apache.org%3E
MLIST https://lists.apache.org/thread.html/re473305a65b4db888e3556e4dae10c2a04ee89dcff2e26ecdbd860a9@%3Ccvs.httpd.apache.org%3E
MLIST https://lists.apache.org/thread.html/r76142b8c5119df2178be7c2dba88fde552eedeec37ea993dfce68d1d@%3Ccvs.httpd.apache.org%3E

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:* http_server >= 2.4.17 <= 2.4.38

Vulnerable and fixed packages

Source package Branch Version Maintainer Status