CVE-2018-9057

Name
CVE-2018-9057
Description
aws/resource_aws_iam_user_login_profile.go in the HashiCorp Terraform Amazon Web Services (AWS) provider through v1.12.0 has an inappropriate PRNG algorithm and seeding, which makes it easier for remote attackers to obtain access by leveraging an IAM account that was provisioned with a weak password.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Issue Tracking https://github.com/terraform-providers/terraform-provider-aws/pull/3934

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:hashicorp:terraform:*:*:*:*:*:aws:*:* terraform >= None <= 1.12.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
terraform 3.14-community 0.14.9-r2 Thomas Boerger <thomas@webhippie.de> possibly vulnerable
terraform edge-community 1.0.7-r0 Thomas Boerger <thomas@webhippie.de> possibly vulnerable