An issue was discovered in Foxit Reader before 9.1 and PhantomPDF before 9.1. This vulnerability allows remote attackers to execute arbitrary code. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists when rendering U3D images inside of pdf files. The issue results from the lack of proper validation of user-supplied data, which can result in a type confusion condition. An attacker can leverage this to execute code in the context of the current process.
NVD Severity
Other trackers
Mailing lists
GitHub (code, issues), Aports (code, issues)


Type URI
Vendor Advisory
Third Party Advisory
Third Party Advisory

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:foxitsoftware:reader:*:*:*:*:*:*:*:* reader >= None <=
cpe:2.3:a:foxitsoftware:phantompdf:*:*:*:*:*:*:*:* phantompdf >= None <=

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
reader 3.19-community 0.4.4-r4 Adam Thiede <> possibly vulnerable
reader 3.20-community 0.4.4-r5 Adam Thiede <> possibly vulnerable
reader edge-community 0.4.4-r5 Adam Thiede <> possibly vulnerable