CVE-2018-7161

Name
CVE-2018-7161
Description
All versions of Node.js 8.x, 9.x, and 10.x are vulnerable and the severity is HIGH. An attacker can cause a denial of service (DoS) by causing a node server providing an http2 server to crash. This can be accomplished by interacting with the http2 server in a manner that triggers a cleanup bug where objects are used in native code after they are no longer available. This has been addressed by updating the http2 implementation.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Patch https://nodejs.org/en/blog/vulnerability/june-2018-security-releases/
Third Party Advisory http://www.securityfocus.com/bid/106363
GENTOO https://security.gentoo.org/glsa/202003-48

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:* nodejs >= 10.0.0 <= 10.7.0
cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:* nodejs >= 9.0.0 <= 9.11.2
cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:* nodejs >= 8.0.0 < 8.11.3

Vulnerable and fixed packages

Source package Branch Version Maintainer Status