CVE-2018-5679

Name
CVE-2018-5679
Description
This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Foxit Reader before 9.1 and PhantomPDF before 9.1. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the processing of specially crafted pdf files with embedded u3d images. The issue results from the lack of proper validation of user-supplied data, which can result in a read past the end of an allocated object. An attacker can leverage this in conjunction with other vulnerabilities to execute code in the context of the current process, a different vulnerability than CVE-2018-5677 and CVE-2018-5680.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Vendor Advisory https://www.foxitsoftware.com/support/security-bulletins.php
Third Party Advisory https://srcincite.io/advisories/src-2018-0015/
Third Party Advisory http://www.securityfocus.com/bid/104300

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:foxitsoftware:reader:*:*:*:*:*:*:*:* reader >= None <= 9.0.1.1049
cpe:2.3:a:foxitsoftware:phantompdf:*:*:*:*:*:*:*:* phantompdf >= None <= 9.0.1.1049

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
reader 3.19-community 0.4.4-r4 Adam Thiede <me@adamthiede.com> possibly vulnerable
reader edge-community 0.4.4-r4 Adam Thiede <me@adamthiede.com> possibly vulnerable