CVE-2018-21240

Name
CVE-2018-21240
Description
An issue was discovered in Foxit Reader and PhantomPDF before 9.2. It allows memory consumption via an ArrayBuffer(0xfffffffe) call.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Vendor Advisory https://www.foxitsoftware.com/support/security-bulletins.php

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:foxitsoftware:phantompdf:*:*:*:*:*:*:*:* phantompdf >= None < 9.2
cpe:2.3:a:foxitsoftware:reader:*:*:*:*:*:*:*:* reader >= None < 9.2

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
reader 3.19-community 0.4.4-r4 Adam Thiede <me@adamthiede.com> possibly vulnerable
reader edge-community 0.4.4-r4 Adam Thiede <me@adamthiede.com> possibly vulnerable