CVE-2018-20750

Name
CVE-2018-20750
Description
LibVNC through 0.9.12 contains a heap out-of-bounds write vulnerability in libvncserver/rfbserver.c. The fix for CVE-2018-15127 was incomplete.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Exploit https://www.openwall.com/lists/oss-security/2018/12/10/8
Issue Tracking https://github.com/LibVNC/libvncserver/issues/273
Patch https://github.com/LibVNC/libvncserver/commit/09e8fc02f59f16e2583b34fe1a270c238bd9ffec
Third Party Advisory https://usn.ubuntu.com/3877-1/
Mailing List https://lists.debian.org/debian-lts-announce/2019/01/msg00029.html
Third Party Advisory http://www.securityfocus.com/bid/106825
MLIST https://lists.debian.org/debian-lts-announce/2019/10/msg00042.html
UBUNTU https://usn.ubuntu.com/4547-1/
UBUNTU https://usn.ubuntu.com/4587-1/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:libvncserver_project:libvncserver:*:*:*:*:*:*:*:* libvncserver >= None <= 0.9.12

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
libvncserver 3.11-main 0.9.12-r1 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable