CVE-2018-20359

Name
CVE-2018-20359
Description
An invalid memory address dereference was discovered in the sbrDecodeSingleFramePS function of libfaad/sbr_dec.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Exploit https://github.com/knik0/faad2/issues/29
DEBIAN https://www.debian.org/security/2019/dsa-4522
BUGTRAQ https://seclists.org/bugtraq/2019/Sep/28
GENTOO https://security.gentoo.org/glsa/202006-17

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:audiocoding:freeware_advanced_audio_decoder_2:2.8.8:*:*:*:*:*:*:* freeware_advanced_audio_decoder_2 == None == 2.8.8

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
faad2 3.10-main 2.9.0-r0 Natanael Copa <ncopa@alpinelinux.org> fixed