CVE-2018-20313

Name
CVE-2018-20313
Description
Foxit Reader before 9.5, and PhantomPDF before 8.3.10 and 9.x before 9.5, has a proxyPreviewAction race condition that can cause a stack-based buffer overflow or an out-of-bounds read.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Vendor Advisory https://www.foxitsoftware.com/support/security-bulletins.php

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:foxitsoftware:phantompdf:*:*:*:*:*:*:*:* phantompdf >= None < 8.3.10
cpe:2.3:a:foxitsoftware:phantompdf:*:*:*:*:*:*:*:* phantompdf >= 9.0 < 9.5
cpe:2.3:a:foxitsoftware:reader:*:*:*:*:*:*:*:* reader >= None < 9.5

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
reader 3.19-community 0.4.4-r4 Adam Thiede <me@adamthiede.com> possibly vulnerable
reader edge-community 0.4.4-r4 Adam Thiede <me@adamthiede.com> possibly vulnerable