CVE-2018-19477

Name
CVE-2018-19477
Description
psi/zfjbig2.c in Artifex Ghostscript before 9.26 allows remote attackers to bypass intended access restrictions because of a JBIG2Decode type confusion.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Release Notes https://www.ghostscript.com/doc/9.26/History9.htm#Version9.26
Issue Tracking https://bugs.ghostscript.com/show_bug.cgi?id=700168
Patch http://git.ghostscript.com/?p=ghostpdl.git;h=606a22e77e7f081781e99e44644cd0119f559e03
Patch http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=ef252e7dc214bcbd9a2539216aab9202848602bb
Third Party Advisory https://www.debian.org/security/2018/dsa-4346
Mailing List https://lists.debian.org/debian-lts-announce/2018/11/msg00036.html
Third Party Advisory https://usn.ubuntu.com/3831-1/
Third Party Advisory http://www.securityfocus.com/bid/106154
Mitigation https://semmle.com/news/semmle-discovers-severe-vulnerability-ghostscript-postscript-pdf
Third Party Advisory https://access.redhat.com/errata/RHSA-2019:0229
Third Party Advisory https://access.redhat.com/errata/RHBA-2019:0327

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:artifex:ghostscript:*:*:*:*:*:*:*:* ghostscript >= None < 9.26

Vulnerable and fixed packages

Source package Branch Version Maintainer Status