CVE-2018-16858

Name
CVE-2018-16858
Description
It was found that libreoffice before versions 6.0.7 and 6.1.3 was vulnerable to a directory traversal attack which could be used to execute arbitrary macros bundled with a document. An attacker could craft a document, which when opened by LibreOffice, would execute a Python method from a script in any arbitrary file system location, specified relative to the LibreOffice install location.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Vendor Advisory https://www.libreoffice.org/about-us/security/advisories/cve-2018-16858/
Issue Tracking https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16858
Exploit http://packetstormsecurity.com/files/152560/LibreOffice-Macro-Code-Execution.html
Exploit https://www.exploit-db.com/exploits/46727/
Third Party Advisory http://www.rapid7.com/db/modules/exploit/multi/fileformat/libreoffice_macro_exec
REDHAT https://access.redhat.com/errata/RHSA-2019:2130
BUGTRAQ https://seclists.org/bugtraq/2019/Aug/28
SUSE http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00059.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:libreoffice:libreoffice:*:*:*:*:*:*:*:* libreoffice >= None < 6.0.7
cpe:2.3:a:libreoffice:libreoffice:*:*:*:*:*:*:*:* libreoffice >= 6.1.0 < 6.1.3

Vulnerable and fixed packages

Source package Branch Version Maintainer Status