CVE-2018-15599

Name
CVE-2018-15599
Description
The recv_msg_userauth_request function in svr-auth.c in Dropbear through 2018.76 is prone to a user enumeration vulnerability because username validity affects how fields in SSH_MSG_USERAUTH messages are handled, a similar issue to CVE-2018-15473 in an unrelated codebase.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Third Party Advisory https://old.reddit.com/r/blackhat/comments/97ywnm/openssh_username_enumeration/e4e05n2/
Mailing List http://lists.ucc.gu.uwa.edu.au/pipermail/dropbear/2018q3/002109.html
Mailing List http://lists.ucc.gu.uwa.edu.au/pipermail/dropbear/2018q3/002108.html
Mailing List https://lists.debian.org/debian-lts-announce/2018/08/msg00026.html
CONFIRM https://matt.ucc.asn.au/dropbear/CHANGES

Match rules

CPE URI Source package Min version Max version
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* debian_linux == None == 8.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status