CVE-2018-13259

Name
CVE-2018-13259
Description
An issue was discovered in zsh before 5.6. Shebang lines exceeding 64 characters were truncated, potentially leading to an execve call to a program name that is a substring of the intended one.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Mailing List https://www.zsh.org/mla/zsh-announce/136
Patch https://sourceforge.net/p/zsh/code/ci/1c4c7b6a4d17294df028322b70c53803a402233d
Mailing List https://bugs.debian.org/908000
Third Party Advisory https://usn.ubuntu.com/3764-1/
Third Party Advisory https://security.gentoo.org/glsa/201903-02
REDHAT https://access.redhat.com/errata/RHSA-2019:2017
MLIST https://lists.debian.org/debian-lts-announce/2020/12/msg00000.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* ubuntu_linux == None == 18.04
cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* ubuntu_linux == None == 14.04
cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* ubuntu_linux == None == 16.04

Vulnerable and fixed packages

Source package Branch Version Maintainer Status