CVE-2018-1172

Name
CVE-2018-1172
Description
This vulnerability allows remote attackers to deny service on vulnerable installations of The Squid Software Foundation Squid 3.5.27-20180318. Authentication is not required to exploit this vulnerability. The specific flaw exists within ClientRequestContext::sslBumpAccessCheck(). A crafted request can trigger the dereference of a null pointer. An attacker can leverage this vulnerability to create a denial-of-service condition to users of the system. Was ZDI-CAN-6088.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Third Party Advisory https://zerodayinitiative.com/advisories/ZDI-18-309
Vendor Advisory http://www.squid-cache.org/Advisories/SQUID-2018_3.txt

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:squid-cache:squid:3.5.27:*:*:*:*:*:*:* squid == None == 3.5.27

Vulnerable and fixed packages

Source package Branch Version Maintainer Status