CVE-2018-1160

Name
CVE-2018-1160
Description
Netatalk before 3.1.12 is vulnerable to an out of bounds write in dsi_opensess.c. This is due to lack of bounds checking on attacker controlled data. A remote unauthenticated attacker can leverage this vulnerability to achieve arbitrary code execution.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Exploit https://www.tenable.com/security/research/tra-2018-48
Release Notes https://github.com/tenable/poc/tree/master/netatalk/cve_2018_1160/
Third Party Advisory https://attachments.samba.org/attachment.cgi?id=14735
Release Notes http://netatalk.sourceforge.net/3.1/ReleaseNotes3.1.12.html
Third Party Advisory https://www.debian.org/security/2018/dsa-4356
Exploit https://www.exploit-db.com/exploits/46034/
Third Party Advisory https://www.synology.com/security/advisory/Synology_SA_18_62
Exploit https://www.exploit-db.com/exploits/46048/
Third Party Advisory http://www.securityfocus.com/bid/106301
Exploit https://www.exploit-db.com/exploits/46675/
Exploit http://packetstormsecurity.com/files/152440/QNAP-Netatalk-Authentication-Bypass.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:netatalk_project:netatalk:*:*:*:*:*:*:*:* netatalk >= None < 3.1.12

Vulnerable and fixed packages

Source package Branch Version Maintainer Status