CVE-2018-1123

Name
CVE-2018-1123
Description
procps-ng before version 3.3.15 is vulnerable to a denial of service in ps via mmap buffer overflow. Inbuilt protection in ps maps a guard page at the end of the overflowed buffer, ensuring that the impact of this flaw is limited to a crash (temporary denial of service).
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Exploit https://www.qualys.com/2018/05/17/procps-ng-audit-report-advisory.txt
Issue Tracking https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1123
Mailing List http://seclists.org/oss-sec/2018/q2/122
Third Party Advisory https://www.debian.org/security/2018/dsa-4208
Third Party Advisory https://usn.ubuntu.com/3658-1/
Third Party Advisory http://www.securityfocus.com/bid/104214
Third Party Advisory https://www.exploit-db.com/exploits/44806/
Third Party Advisory https://lists.debian.org/debian-lts-announce/2018/05/msg00021.html
Third Party Advisory https://usn.ubuntu.com/3658-3/
Third Party Advisory https://security.gentoo.org/glsa/201805-14
SUSE http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00058.html
SUSE http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00059.html
MLIST https://lists.apache.org/thread.html/rf4c02775860db415b4955778a131c2795223f61cb8c6a450893651e4@%3Cissues.bookkeeper.apache.org%3E
MLIST https://lists.apache.org/thread.html/r58af02e294bd07f487e2c64ffc0a29b837db5600e33b6e698b9d696b@%3Cissues.bookkeeper.apache.org%3E

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:procps-ng_project:procps-ng:*:*:*:*:*:*:*:* procps-ng >= None < 3.3.15

Vulnerable and fixed packages

Source package Branch Version Maintainer Status