CVE-2018-1122

Name
CVE-2018-1122
Description
procps-ng before version 3.3.15 is vulnerable to a local privilege escalation in top. If a user runs top with HOME unset in an attacker-controlled directory, the attacker could achieve privilege escalation by exploiting one of several vulnerabilities in the config_file() function.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Exploit https://www.qualys.com/2018/05/17/procps-ng-audit-report-advisory.txt
Issue Tracking https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1122
Mailing List http://seclists.org/oss-sec/2018/q2/122
Third Party Advisory https://www.debian.org/security/2018/dsa-4208
Third Party Advisory https://usn.ubuntu.com/3658-1/
Third Party Advisory http://www.securityfocus.com/bid/104214
Exploit https://www.exploit-db.com/exploits/44806/
Third Party Advisory https://lists.debian.org/debian-lts-announce/2018/05/msg00021.html
Third Party Advisory https://usn.ubuntu.com/3658-3/
Third Party Advisory https://security.gentoo.org/glsa/201805-14
REDHAT https://access.redhat.com/errata/RHSA-2019:2189
SUSE http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00058.html
SUSE http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00059.html
REDHAT https://access.redhat.com/errata/RHSA-2020:0595

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:procps-ng_project:procps-ng:*:*:*:*:*:*:*:* procps-ng >= None < 3.3.15

Vulnerable and fixed packages

Source package Branch Version Maintainer Status