CVE-2018-1000874

Name
CVE-2018-1000874
Description
** DISPUTED ** PHP cebe markdown parser version 1.2.0 and earlier contains a Cross Site Scripting (XSS) vulnerability in all distributed parsers allowing a malicious crafted script to be executed that can result in the lose of user data and sensitive user information. This attack can be exploited by crafting a three backtick wrapped payload with a character in front: L: "```<script>alert();</script>```". NOTE: This has been argued as a non-issue (see references) since it is not the parser's job to sanitize malicious code from a parsed document.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Exploit https://github.com/cebe/markdown/issues/166
MISC https://github.com/cebe/markdown/issues/166#issuecomment-508230493

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:cebe:markdown:*:*:*:*:*:*:*:* markdown >= None <= 1.2.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
markdown edge-community 1.0.1-r2 Kevin Daudt <kdaudt@alpinelinux.org> fixed
markdown 3.14-community 1.0.1-r2 Kevin Daudt <kdaudt@alpinelinux.org> fixed
markdown 3.15-community 1.0.1-r2 Kevin Daudt <kdaudt@alpinelinux.org> possibly vulnerable