CVE-2018-1000197

Name
CVE-2018-1000197
Description
An improper authorization vulnerability exists in Jenkins Black Duck Hub Plugin 3.0.3 and older in PostBuildScanDescriptor.java that allows users with Overall/Read permission to read and write the Black Duck Hub plugin configuration.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Vendor Advisory https://jenkins.io/security/advisory/2018-05-09/#SECURITY-670

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:black_duck_hub:*:*:*:*:*:jenkins:*:* jenkins >= None <= 3.0.3

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.14-community 2.297-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.307-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable