CVE-2017-20147

Name
CVE-2017-20147
Description
In the ebuild package through smokeping-2.7.3-r1 for SmokePing on Gentoo, the initscript uses a PID file that is writable by the smokeping user. By writing arbitrary PIDs to that file, the smokeping user can cause a denial of service to arbitrary PIDs when the service is stopped.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://bugs.gentoo.org/631140
GENTOO https://security.gentoo.org/glsa/202209-08

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:smokeping:smokeping:*:*:*:*:*:*:*:* smokeping >= None <= 2.7.3-r1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
smokeping edge-main 2.7.3-r8 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
smokeping 3.16-main 2.7.3-r7 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
smokeping 3.15-main 2.7.3-r7 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
smokeping 3.14-main 2.7.3-r5 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
smokeping 3.13-main 2.7.3-r5 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable